Texts messaging service is down
Incident Report for MarketMan
Postmortem

Stuck job

Posted May 30, 2021 - 07:15 UTC

Resolved
This incident has been resolved.
Posted May 30, 2021 - 07:15 UTC
Investigating
We are currently investigating this issue.
Posted May 30, 2021 - 07:13 UTC
This incident affected: Communications.